wifi not connecting - factory reset possible/helpful?

My Kinoma create suddenly stopped connecting to my wifi network. No networks are found, in the wifi app (other devices still connect to wifi, so I know it's not simply my network going down). Perusing these discussion boards, I saw a suggestion to check the MAC ID on the device - it is still present, and apparently valid.

I wonder if something else in the firmware could have become corrupted. Is there a way to do a factory reset on the device? One option might be to boot from a bootable sdcard - is there a documented procedure for putting an image on an sdcard?

Answers

  • Good evening,

    Is this an original Create or a Create V2? If you're not sure, roughly how long have you had it?

    Thanks,

    Will

  • Hi Will, I think it's an original Create. I've had it for over a year, and in the Settings app, it says, "Model: Version 1".

  • Greetings!

    Sorry to hear that you're having Wi-Fi problems. With some luck, we should be able to get you back up and running pretty quickly.

    To start, are you comfortable working from the command line? If so, I can walk you through some steps to reset the Wi-Fi on the device using the FTDI/serial connection over the mini usb port.

    Would that work for you?

    — Andy

  • The command line is fine with me, it's windows 10, though. Hopefully that won't pose an obstacle. I do have cygwin/bash installed.

  • Oh, if need be I can hook the Create up to an Ubuntu machine (14.04.4 LTS).

  • Great! So, the first step is to get that connection working. I've had good luck using Putty to connect to the device on Windows 10. With your Kinoma Create plugged into your PC via the mini (not micro) USB port, you should be able to connect to it via a serial connection in putty. You can look up the proper comm port in device manager (let me know if you have trouble getting that working and I can put together a quick video on it).

    From Ubuntu, you could just use minicom or screen. Screen is probably easiest. If you go to /dev/ with the device plugged in and ls tty.usb* you should see something with a long name like tty.usb-A83487EF7. You would then screen tty.usb-A83487EF7 115200 to connect to the device. Login is kinoma, password is Kinoma123.

    Next: what to do once you're in there... There are a couple of bits of information that would be helpful to me. 1) Could you type ifconfig and post whatever you get back? I'm curious to see whether or not the mlan0 interface is even there. 2) If it is, most likely you just somehow have a corrupt WiFi configuration saved. You can delete a couple of different places. First, in the /root/.kinoma director you could delete everything (assuming you don't have any saved data you're too worried about):

     cd /root/.kinoma
     rm -r *
     sync
     reboot
    

    And see if that helps. If that's no good, it may be in the actual wpa_conf file. I'll dig up an original Kinoma Create at the office tomorrow to point you in the right direction on that.

    Sorry again for the hassle! — Andy

  • Ok, progress! I was able to connect to the create using putty. I had to download and install the drivers from FTDI. Windows identified the com port baud rate as 9600, but I by trial and error I figured out that it's actually 115200 - then I noticed the correct rate in your "screen" instructions, oops.

    ifconfig did show the mlan0 interface, so I went ahead and deleted everything in /root/.kinoma. After rebooting, wifi works again!

    Next, I tried downloading my app, and ran into trouble. The create is recognized by Kinoma Studio, and download and run occurs without error (according to the UI). However, the app doesn't run - the downloading screen flickers momentarily on the Create, and then it displays the home screen again. I tried some of the sample apps as well - same thing. For the balls sample app, I get:

    [DEBUG]: Connecting to debug client [DEBUG]: Remote connection established... [DEBUG]: Uploading file (application.xml) [DEBUG]: Uploading file (src/balls.js) [DEBUG]: Uploading file (src/balls.png) [DEBUG]: Launching application (balls.example.kinoma.marvell.com)

    then when I do "Stop" in Studio, I get: [DEBUG]: Disconnecting from debug client

    Maybe I need to restore something in /root/.kinoma - any ideas?

  • Sorry, I couldn't remember how to format posts here, and now I can't edit my post. Here is the console output, this time formatted, for my attempt to download the balls sample app:

    [DEBUG]: Connecting to debug client [DEBUG]: Remote connection established... 
    [DEBUG]: Uploading file (application.xml) [DEBUG]: Uploading file (src/balls.js)
    [DEBUG]: Uploading file (src/balls.png)
    [DEBUG]: Launching application (balls.example.kinoma.marvell.com)
    

    after "Stop" in Studio:

    [DEBUG]: Disconnecting from debug client
    
  • Answer ✓

    Glad you could get logged in and got Wi-Fi back up and running! An excellent start. Sorry for a bit of confusion on my part on the login name above (should be root, not kinoma) -- I'm rusty on my Kinoma Create Version 1 details, it seems.

    I think the issue you're seeing now has an easy fix. You're just missing a symlink to /tmp/cache. You should be able to fix it with:

     cd /root/.kinoma/kdt
     ln -s /tmp/cache cache
    

    When I tried these steps, my Kinoma Create Version 1 correctly restored the similar symlink in /root/.kinoma/, but if yours did not you can replace it too:

     cd /root/.kinoma
     ln -s /tmp/cache cache
    

    Please give that a shot and see if it resolves your issue running from studio.

    Cheers!

    • Andy
  • Great, that did the trick. I found that /root/.kinoma/cache already existed as a symlink to /tmp/cache, but /root/.kinoma/kdt/cache existed as a regular directory. I deleted /root/.kinoma/kdt/cache, and made the suggested symlink; then I was able to download my app as usual - I didn't even have to reboot.

    Thanks for the help!

  • Great — glad you got back up and running! Sorry for the trouble. I wonder what happened to your Wi-Fi configuration in the first place...

Sign In or Register to comment.