No Wifi SSID

edited May 2016 in Kinoma Element

Hi I took my Element, plugged it into my Macbook's USB port and launched Kinoma Code. The LED on the Element is blinking Blue, perhaps 1 time per second - blue is not listed on the getting started guide list of LED state indicators .

I don't see any Wifi SSD with the name "Kinoma Element..." or anything like it. In code, I see a device on USB named Kinoma Element on /dev/cu.usbmodem...

I tried resetting using a paper clip in the small reset hole next to the USB port, it did not help.

I cannot seem to get any further at this point. Can anyone tell me how to get this running?

Thanks

Comments

  • edited May 2016

    Hello,

    Sorry you're having trouble--the blue flashing may mean your device settings are corrupted. The good news is you should be able to fix it through the USB console. You can use Kinoma Code to do that by selecting the USB device (/dev/cu.usbmodem...) from the dropdown menu. From there you can enter commands as described in the reference document for Kinoma Element.

    I've seen cases where the MAC address of the Element is lost, which causes Wi-Fi to be disabled. Try entering printenv into the console and take a look at the output. You should see something like this:

    FW_VER=1.1.0
    MAC=5043039215
    HOST=Kinoma Element-005043039215
    UUID=00022595-2595-1002-D899-005043039215
    XSBUG_HOST=192.168.1.3:5003
    TIME_DIFF=-480
    DST=60
    APP_ID=hullo.project.kinoma.marvell.com
    

    If you don't see a MAC address there, try the following commands:

    setenv MAC “005043039216”
    saveenv
    reboot
    

    When your Kinoma Element has fully rebooted it should return to access point mode and work as described in the quick start guide.

    If that doesn't help, please send me the output you see in the console after you enter wifi and printenv and I'll help you figure out what went wrong.

    When you type wifi and press enter, you should see something like this:

    {
          init: function(...) { ... },
          fin: function(...) { ... },
          start: function(...) { ... },
          dhcpName: undefined,
          _connect: function(...) { ... },
          disconnect: function(...) { ... },
          close: function(...) { ... },
          ip: "192.168.1.23",
          mac: "005043039215",
          setmac: function(...) { ... },
          rssi: -48,
          scan: function(...) { ... },
          status: 5,
          mode: 1,
          config: {
                save: true,
                state: 1,
                mode: 0,
                ssid: "579 9th - slow",
                bssid: "04a151e0c36a",
                password: "******",
                security: 2,
                hidden: false
          },
          ssid: "579 9th - slow",
          getInterfaces: function(...) { ... },
          stat: function(...) { ... },
          load: function(...) { ... },
          connect: function(...) { ... },
          notify: function(...) { ... },
          onScanComplete: function(...) { ... },
          run: function(...) { ... }
    }
    

    Hope this helps!

  • Hi Lizzie thanks for the quick response! I do have a MAC address. I also noticed an SSID "k5-0050430390da" in the output of Wifi, to which I could connect and I was assigned an IP address but there was no web server at 192.168.0.1.

    Here is my entire console output when connected via USB, including the printenv and wifi commands' output

    [net] configuring interface uap (with Static IP)

    wlan: UAP success

    connected: 192.168.0.1

    inetd: starting... mode = 2

    inetd: starting udp:6969

    inetd: starting tcp:2323

    inetd: starting tcp:10000

    inetd: starting tcp:8081

    inetd: running

    [k5-0050430390da]$ printenv

    .ver=1

    LOG=3

    FW_VER=0.99.7

    HOST=k5-0050430390da

    MAC=0050430390da

    UUID=0001744E-744E-1001-EF6A-0050430390da

    [k5-0050430390da]$ wifi

    {

    init: function(...) { ... },

    fin: function(...) { ... },

    connect: function(...) { ... },

    disconnect: function(...) { ... },

    ip: "192.168.0.1",

    mac: "0050430390da",

    _setmac: function(...) { ... },

    rssi: -256,

    scan: function(...) { ... },

    save: function(...) { ... },

    status: 4,

    mode: 2,

    config: {

    save: false,
    
    state: 1
    

    },

    ssid: "k5-0050430390da",

    getInterfaces: function(...) { ... },

    stat: function(...) { ... },

    MODEBITS: 8,

    MODEMASK: 255,

    WAC: 256,

    SINGLEUSER: 512,

    FWUPDATE: 1024

    }

    [k5-0050430390da]$ wlan: client assoc/dissoc

    PowerGround: init

    StudioHTTPServer: onRequest: /description

    from: 192.168.0.2:52511

    StudioHttpService: calling _description

    StudioHTTPServer: onClose: connected = false

    inetd: onClose callback: 10000

  • I did a little more digging and managed to connect to my Element, rename it and join a Wifi network. The LED remains blue, not green (steady LED now) and I was presented with the chance to "apply" the update to 2.0.0 from 0.99.7

    The update advised me to stay powered, etc. It then said that it was downloading and after several seconds I was told that the update to 2.0.0 failed, please try again later. :(

  • The above left my device back at WAP mode, I connected it to my network and tried to apply the update several times, with the same "failed" result.

  • edited May 2016

    If it's steady that's a good sign; a blue blink-blink-pause pattern usually means something is wrong but older firmware versions had different status light colors so if your device connects to Wi-Fi it should be fine.

    It is strange that it goes back into AP mode when the update fails. I'll see if anyone here has seen that problem before and let you know when we figure out why that would happen.

    Are you comfortable using Terminal? If so, you might try doing the first update from there. To do that, you'll want to:

    1) Open the USB console:

    sudo cu  -l /dev/cu.usbmodem...
    

    2) Connect to your Wi-Fi network. If it's password protected use:

    connect "network name" wpa2 "password" 0 true
    

    If not, use:

    connect "network name" none undefined 0 true
    

    3) Update the device:

    update
    

    Let me know if that works or if you need more detailed instructions on using Terminal.

  • Hi I did this and got some more info on the failure - it looks like a problem on the server side

    wlan: UAP success connected: 192.168.0.1 inetd: starting... mode = 2 inetd: starting udp:6969 inetd: starting tcp:2323 inetd: starting tcp:10000 inetd: starting tcp:8081 inetd: running [tronn]$ update inetd: stopped 6969 inetd: stopped 2323 inetd: stopped 10000 [tronn]$ download: HTTP failed 505 Internal Server Error

  • I tried again just now and it worked! All seems well. Thanks

  • Excellent, glad you were successful!

Sign In or Register to comment.