when I update from 1.3.49 to 1.3.57 studio won't start

An error has occurred, see log file, which complains about org.osgi.framework.BundleException: Could not resolve module: com.marvell.kinoma.blockly

!SESSION 2016-03-18 17:12:06.872 ----------------------------------------------- eclipse.buildId=unknown java.version=1.6.0_65 java.vendor=Apple Inc.

Answers

  • Hi,

    It looks like you're running an older version of Java. The Blockly modules in particular will fail under Java 6, and require Java 7 (though we suggest using Java 8 if possible).

    Cheers,

    Will

  • I updated to Java 8, but still get same error. The java control panel under system preferences shows Platform = 1.8, but still get the log below

    !SESSION 2016-03-21 15:27:22.512 ----------------------------------------------- eclipse.buildId=unknown java.version=1.6.0_65 java.vendor=Apple Inc. BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US Framework arguments: -keyring /Users/webster/.eclipse_keyring -showlocation Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/webster/.eclipse_keyring -showlocation

    BTW

    https://java.com/en/download/installed.jsp

    also shows 8

    Verified Java Version Completion checkmark Congratulations! You have the recommended Java installed (Version 8 Update 73).

  • Duh. Figured it out. Installed the JRE not the JDK. TX! :)

Sign In or Register to comment.