trace() output is not coming on console when running on Kinoma device

The trace("abc") output is not coming on console when I am running my application on Kinoma devie. When I run the application on Simulator, it is working fine. I am using Ubuntu 14.04, 64 bit operating system, Java version is 8 and Kinoma studio version is 1.3.49

Thanks.

Answers

  • Hi,

    First, is your Create auto-detected by Studio, or did you have to add it manually? Also, other than this, is your app running normally on the Create?

    Just to confirm, when you launch your app to your Create, do you see something similar to these lines in the Studio "Console" window? Do you see any additional lines?

     [DEBUG]: Connecting to debug client
     [DEBUG]: Remote connection established...
     [DEBUG]: Launching application (basiccheckbox.example.kinoma.marvell.com)
    

    Let me know on these things and we'll work through this.

    Cheers,

    Will

    1. I had to add my create manually. It was not auto detected.
    2. My app is running perfectly other than trace() output on console.
    3. On the console window I can see the exact lines posted by you.
  • When Create starts up an app it tries to connect back to Studio on port 10000.

    Do you have a firewall of any type setup on this machine? If so, allowing inbound traffic from the Create on TCP port 10000 should correct this.

    Is this a physical or virtual machine? If it is virtual, are you using bridged networking or some type of NAT? Unless you can forward this port, NAT will prevent this connection from working.

    Cheers,

    Will

  • edited March 2016

    I am using virtual machine. I have forwarded 10000 port in NAT but still there is no change in the situation. To clarify, in port forwarding under NAT my guest port and host port would be the same (10000). Is that correct?

  • Hi,

    My apologies, I got a few details mixed up in my last post. Here's the (actual) situation: First, Studio listens on port 5002 for a debugging connection from Create (not 10000). Second, when Studio sends the app over to Create, it includes a configuration file with the IP of the system Studio is running on. Create determines where to send its debugging data based on the IP in that file.

    This is unfortunately bad news for your situation as the IP address Create is trying to use is the private IP (behind NAT) - this IP doesn't exist on the Create's subnet, so the connection will never be made - even if you forward ports back properly. There is not a work around for this within Studio at the moment.

    If you're in a situation where you can't get around using NAT between your Create and Studio, you do have one other option - building your source using the OSS KinomaJS tools. The manifest.json file referenced in that section can contain any destination you like for the debug data; so you could point it at the public side of your VM's NAT adapter and then forward port 5002 back. If you're interested in going this route, let me know and I can provide some additional information about the manifest.json file as well as the steps required to prepare Studio to listen for the debug data without directly launching an app.

    Cheers,

    Will

  • HI Will, Thanks for your detailed explanation of this issue. I think, at this point it will be good if you can provide me the steps required to prepare Studio to listen for the debug data without directly launching an app.

  • Hi,

    There are two stages to setting up Studio as a remote debugger; installing XSBUG and creating an XSBUG configuration.

    First, installing XSBUG:

    1) Go to Help -> Install New Software

    2) In the window that appears Set "Work with" to Kinoma Studio Updates - http://tools.kinoma.com/studio/update/release/1.3

    3) Type "xsbug" (no quotes) in the filter box

    4) Check the box next to Kinoma XSBUG when it appears

    5) Hit next, accept the license agreement and hit finish. The installation may take several minutes. Restart Studio when prompted.

    Second, creating an XSBUG run configuration:

    1) Go to Run -> Run Configurations

    2) Highlight XSBUG, then click the "New" icon above the list

    3) The default settings are all fine, feel free to rename the config to something more appropriate.

    4) Click "Run", XSBUG will launch and display the socket it is listening on in the left-hand pane.

    Note: On my machine, XSBUG shows it is listening on 127.0.1.1, when it is in fact listening on all available interfaces.

    Please let me know if you run into any trouble.

    Cheers,

    Will

Sign In or Register to comment.