Kinoma create not booting !

My KC keeps freeze on the splash screen when booting up. It happened after I loaded a new app from KS. The app was working, then I change the setting so that the KC would start it automatically upon booting up. I have tried restarting, removing the battery and power, pressed the reset button with a paper clip, etc .. The device is not connected to the wifi network. I haven't tried connecting thru USB.

Answers

  • Hello -

    You can try using the Global Quit gesture described on our Kinoma Create Tips page. That should hopefully get you back to the home screen, where you can change the startup app from Settings.

    Regards, Brian

  • Thanks for the suggestion but the device is completely unresponsive. I am not sure it even loads my app. Is there a way I can boot it from an SD card and then re-install the system ? Unfortunately, had created a bootable SD card.

  • edited February 2015 Answer ✓

    I'm assuming you meant to write that you do not have a bootable SD card. Unfortunately you need to use the shell to create one, and the shell isn't loading.

    The First Step: See If It Still Has an Internet Connection

    Let's see how far it's getting through the boot process, and if it's connecting to Wi-Fi. To do this, you'll need to get into the Create console. Once you're there, post here and we'll proceed to troubleshoot.

    Best Approach: Serial Connection

    The best way to start is with a serial connection to the device, since that does not require that the device be connected to Wi-Fi and we get to see all the stuff that is output to the console while it's booting. Can you connect the device to a computer via mini-USB to USB cable? (NOT the micro-USB charging port!) (Be sure to install the FTDI drivers for your system.) Once you connect to the usbserial port in a terminal emulator (baud rate 115200, 8-1-N) and hit Enter, you should see a command prompt. At the command prompt, type:

    ifconfig
    

    Post the results here.

    Alternate Approach: Telnet In

    It's possible (even probable) that the device is connected via Wi-Fi, it's just the shell that isn't loading. First you must determine your device's IP address. It's shown in Studio in the Application Editor if you haven't quit Studio since the last time it worked, but you may just have to look in your router's admin page -- if there's a list of attached devices, you will hopefully find a wireless device with the MAC address starting with D0:E7:82. If you can determine the IP address, open a command prompt (Applications > Utilities > Terminal on a Mac, Windows-R key, then type cmd (Enter) on Windows).
    Type:

    telnet [ip address]
    

    If asked for a login, use root, password Kinoma123. If that succeeds, then I'm confident we can get you going pretty quickly.

    The Next Step: See What Processes Are Running

    If you get to the command prompt, then type the following and hit enter:

    ps
    

    And post the results here.

  • Thanks. I did manage to Telnet into the device. Here is the process listing

    PID USER TIME COMMAND 1 root 0:09 init 2 root 0:00 [kthreadd] 3 root 0:17 [ksoftirqd/0] 4 root 0:00 [watchdog/0] 5 root 0:00 [events/0] 6 root 0:00 [khelper] 7 root 0:00 [async/mgr] 8 root 0:00 [sync_supers] 9 root 0:00 [bdi-default] 10 root 0:00 [kblockd/0] 11 root 0:01 [pxa2xx-spi.2] 12 root 0:00 [pxa2xx-spi.3] 13 root 0:04 [kmmcd] 14 root 0:00 [bluetooth] 15 root 0:00 [khungtaskd] 16 root 0:00 [kswapd0] 17 root 0:00 [crypto/0] 24 root 0:00 [mtdblockd] 25 root 0:00 [ubi_bgt0d] 26 root 0:00 [krfcommd] 27 root 0:00 [ubifs_bgt0_0] 54 root 0:00 [flush-ubifs_0_0] 58 root 0:00 [MOAL_WORK_QUEUE] 59 root 0:00 [woal_reassoc_se] 61 root 0:00 [ksdioirqd/mmc1] 306 root 0:00 telnetd 370 root 0:00 /usr/sbin/touchd 423 root 0:00 /wpa_1.0/wpa_supplicant -B -O /var/run/wpa_supplicant -i 425 root 0:00 /wpa_1.0/wpa_cli -a /wpa_1.0/wpa_action 428 nobody 0:00 /usr/sbin/mdnsd 465 root 0:00 udhcpc -i mlan0 484 root 0:00 sh /bin/kloop.sh /tmp/K.tgz 485 root 0:00 -/bin/ash 1924 root 0:00 -sh 2310 root 0:00 sleep 1 2311 root 0:00 ps

  • I noticed some tar processes that start and stop and restart periodically. They are visible on this log:

    https://www.dropbox.com/s/ow7l6u0guokhrmg/kinoma runnign processes 2.txt?dl=0

  • Perhaps, I should delete this K.tgz ?

  • Hi CABrouwers,

    I believe that you have a firmware corruption issue. If you're comfortable at the command line, I can walk you through making a bootable SD card. Otherwise, we can ship you an SD card to fix the problem. Let me know which you'd prefer.

  • Thanks for helping. Happy to do it either way, it is probably easier for you to ship me an SD card so I will email you my details. Otherwise if you think it is useful to for the community to memorialize the procedure, I am OK with command line - I am not a linux wiz but I can follow instruction,

  • Happy to ship a card. I'm at acarle@kinoma.com

  • Thanks, I receive the card (and the goodies - Thanks). All is working well now !

  • Great! Sorry for the hassle. Let us know if you run into any more issues with that device.

  • Hello Andy, My KC has some problem, (after resetting,removing battery and after restarting several times) it is not booting. I am not sure but I think its the same firmware corruption issue. If possible, can you post the complete procedure to make a bootable SD card ?

Sign In or Register to comment.