Wifi doesn't work with punctuation in password

Earlier at work I was able to get on a wifi network with no problem. After bringing it home, though, I couldn't do anything to get it to work. I restarted it, flushed the caches ( knew this shouldn't make a difference but tried anyway), tried several different security protocols on my local wifi network (WEP, WPA2, WPA/WPA2 Personal, WPA2 Enterprise) and nothing would work. Finally I thought of simplifying my password and sure enough that worked.

If you can't get connected try an alphanumeric-only password and you'll probably be fine.

Answers

  • Hello -

    Thank you for tracking down the issue and posting a solution!

    I have been able to reproduce the problem. Some punctuation characters seem to trigger the failure, including #?, but ! is accepted. We'll log the issue and take a look.

    Regards, Brian

  • Just got my Kinoma today. I'm having the same problem. My wifi password has multiple spaces and an exclamation point. I know that these things are hard to determine, but what do you think the likelihood of having this bug resolved before Christmas? I am looking forward to giving the Kinoma to my daughter as a present and changing our wifi password would mean resetting a few dozen devices.

  • Hello -

    Sorry to hear that you've been bitten by the same WiFi issue. I am confident that we'll have an update available with a fix before Christmas.

    Regards, Brian

  • Hello -

    We've released a Kinoma Software update which includes a fix for this issue. Kinoma Software updates are delivered over-the-air, so you'll need an internet connection to update. We apologize for the inconvenience.

    Thank you again for your feedback and patience.

    Regards, Brian

  • Awesome! Thank-you, Brian!

    Blair.

  • Hi! Anyone try the new software upgrade.I tried but still unable to connect to wifi in my home wireless router. I upgrade the software upgrade through my handphone.

  • I tried but still unable to connect to wifi in my home wireless router.

    Can you safely share the non-[a-zA-Z] characters you're using that might be the culprit(s)?

    — Charles

  • The wireless router is set to 802.11g. security is set to WPA2-PSK. SSID: Tan Family Password: abcd1234

  • WMcreate -

    Sorry to hear that you're still having trouble connecting. I modified my router (NetGear R6300v2) settings to match the SSID and password you provided and I was able to establish a network connection from my Kinoma Create. We'll investigate further to see if we can find any clues.

    Does rebooting your Kinoma Create resolve the problem?

    Regards, Brian

  • edited December 2014

    WMcreate:

    What is the make and model of your home wireless router?

    Do I understand correctly that you were able to connect the Create to a personal hotspot on your mobile phone in order to upgrade the software?

    Is your firmware version 1.1? (That's also in settings, under the Kinoma Software version)

    You are booted from MicroSD card?

Sign In or Register to comment.